Missing Start/Finish Dates on the Gantt-Chart Screen

Incident Report for WBS Gantt-Chart for Jira Cloud

Postmortem

Incident Summary

After updating the app to Version 1.2.4-AC, some Gantt chart data is missing.

Leadup

This issue was caused by an update included in WBS Gantt-Chart for Jira Version 1.2.4-AC.

Fault

The update introduced a new process that automatically created several custom fields and updated settings to use these fields for storing key scheduling data such as start and finish dates.
This process was intended to execute only during new installations of WBS Gantt-Chart for Jira. However, it was mistakenly triggered during app updates as well.

As a result, unnecessary custom fields were mistakenly created in existing users' Jira instances. Furthermore, the settings were updated to reference these newly created fields, causing WBS Gantt-Chart for Jira to use them instead of the previously configured ones.

Impact

Existing customers who meet all of the following conditions are affected:

  • Customers who updated to version 1.2.4-AC between Wed, Jan 21, at 6:20 PM (PST) and Wed, Jan 22, at 8:15 PM (PST) (※)
  • The issue setting was set to "Use Jira field"
  • At the time of updating from version 1.2.3-AC to 1.2.4-AC, one or more of the following custom fields did not exist in your Jira:

    • Start date (WBS Gantt-Chart)
    • Finish date (WBS Gantt-Chart)
    • Baseline start date (WBS Gantt-Chart)
    • Baseline finish date (WBS Gantt-Chart)
    • Percent done (WBS Gantt-Chart)
    • Units (WBS Gantt-Chart)
    • Manually scheduled (WBS Gantt-Chart)
    • Milestone (WBS Gantt-Chart)

(※) Note: Version 1.2.4-AC was an automatic update. If a user's instance was already on version 1.2.3-AC, it was automatically updated to version 1.2.4-AC without any required action from the user.

Recovery

The day after the release of version 1.2.4-AC, we identified the root cause of the issue, made the necessary fixes, and deployed the corrected version to production. This prevented further occurrences of the issue for subsequent updates.

For customers whose settings had already been updated, we published a step-by-step guide to manually revert the settings. Since some users may have intentionally modified their settings post-update, we decided against a system-wide rollback to prevent unintended changes.

Timeline (All times are in PST)

  • January 21, 6:20 PM - Released WBS Gantt-Chart for Jira 1.2.4-AC.
  • January 22, 12:55 AM - Received the first customer report of incorrect data mapping and began investigation.
  • January 22, 8:15 PM - Deployed the fix to the production environment.
  • January 23, 4:45 AM - Published a step-by-step guide on the documentation site for users to revert their settings.
  • January 29, 5:40 AM - A follow-up announcement email was sent to affected users.

Root Cause

The issue occurred because we didn’t thoroughly test the app’s lifecycle events. In production, updates are done through the Atlassian Marketplace, but our test environment didn’t use the same update process. As a result, we couldn’t accurately predict how the app would behave when updated via the Marketplace before release.

Corrective Actions

To prevent similar issues in the future, we will:

  • Improve our test environment to better mirror the actual production environment.
  • Enhance our understanding of app lifecycle events and their impact on updates.
Posted Jan 30, 2025 - 17:36 PST

Resolved

This incident has been resolved.

However, we require your assistance to revert the configuration to its original state if you are still affected by this incident.

Please refer to the following guide on how to restore the previous configuration:
https://docs.ricksoft-inc.com/wbs-gantt-chart-for-jira-cloud/instruction-for-resolving-missing-start-finish-dat

If you have any questions or encounter any issues during the process, please do not hesitate to contact our support team:
https://ricksoft-support.atlassian.net/servicedesk/customer/portal/3/group/46
Posted Jan 27, 2025 - 21:49 PST

Update

No further impact has been observed
Posted Jan 27, 2025 - 21:48 PST

Monitoring

We have identified an issue affecting Start and Finish dates in WGC Gantt-Chart for Jira.
This issue was caused by a bug that created new Jira custom fields and switched the Gantt configuration to use these fields instead of the original ones.

The issue has been resolved to prevent further impact on new data.
However, for existing data, we require your assistance in reverting the configuration to its original state.

We sincerely apologize for the inconvenience caused and appreciate your understanding.
For detailed instructions on how to restore the previous configuration, please refer to the following guide:
https://docs.ricksoft-inc.com/wbs-gantt-chart-for-jira-cloud/instruction-for-resolving-missing-start-finish-dat

If you have any questions or encounter any issues during the process, please do not hesitate to contact our support team.

Thank you for your cooperation and continued support.
Posted Jan 24, 2025 - 04:51 PST
This incident affected: Gantt screen - View and Gantt settings.