After releasing version 2.17.0, some customers experienced a problem where the Gantt Chart page stopped loading midway. The issue did not affect all environments, but it blocked users in certain network environments from accessing the page. The incident was resolved after fixing a bug related to unnecessary mandatory loading of Atlassian Government Cloud (AGC)-specific resources in non-AGC environments.
Leadup
On Sep 16 19:30 PDT, version 2.17.0 was released.
After the release, the team confirmed that version 2.17.0 appeared to be functioning normally.
No immediate issues were detected through internal monitoring or testing.
Fault
As part of preparations for AGC support, the application started requesting resources from the new domain *.cdn.atlassian-us-gov-mod.com.
Due to a bug, the application treated loading these AGC-specific resources as mandatory for all environments, even for standard Atlassian Cloud environments.
In restricted network environments (e.g. using firewall/proxy that blocks most external domains), these requests failed, which caused the Gantt Chart page to stop loading.
Impact
Affected Users: Customers using restrictive firewall or proxy settings.
Effect: The Gantt Chart page could not fully load, preventing access to essential project management functionality.
Scope: Limited subset of customers; not reproducible in standard network environments.
Recovery
After identifying the root cause, the team modified the application so that AGC-specific resource loading is no longer mandatory in non-AGC environments.
The fix was verified in a test environment, then deployed to production.
After deployment, monitoring confirmed that the Gantt Chart page loaded successfully in affected environments.
Timeline (All times are in PDT)
Time
Description
Sep 16 19:30
Version 2.17.0 released.
Sep 17 20:22
Issue shared with the development team; investigation started.
Sep 17 22:28
Recognized that the problem was not specific to a single customer, and opened an incident on Statuspage to inform all users.
Sep 17 23:18
Root cause identified: AGC-specific resources blocked by restrictive firewall/proxy settings. Temporary workaround suggested.
Sep 18 03:35
Fix deployed to production; monitoring in progress.
Sep 18 03:47
Issue confirmed as resolved.
Root Cause
The application unintentionally treated loading AGC-specific resources as mandatory in all environments due to a logic bug.
This caused the application to fail when those resources were blocked by restrictive firewall or proxy settings, resulting in the Gantt Chart page not loading.
Corrective Actions
Short-term:
Fixed the bug so that AGC-specific resources are not required in non-AGC environments.
Deployed the fix and verified successful loading in affected environments.
Long-term:
Add validation to ensure AGC-specific logic is isolated from non-AGC environments.
Enhance monitoring to detect failures caused by blocked resource requests.
Explore proactive detection methods (synthetic monitoring from various network environments).
Posted Sep 21, 2025 - 17:33 PDT
Resolved
This issue has been resolved.
Posted Sep 18, 2025 - 03:47 PDT
Monitoring
The deployment of the fix to the production environment has been completed, and we are currently checking in the production environment to see if this issue has been resolved.
Posted Sep 18, 2025 - 03:35 PDT
Update
We have confirmed that this issue has been resolved in the test environment and have started deploying the source code to the production environment.
Posted Sep 18, 2025 - 02:44 PDT
Identified
We have identified the root cause of this issue. It occurs when customers are using restrictive firewall or proxy server settings that block access to most external domains.
This behavior started after we made preparations for supporting Atlassian Government Cloud, which introduced requests for resources from *.cdn.atlassian-us-gov-mod.com.
We are currently working on a fix for this issue. As a temporary workaround, customers experiencing this problem can try allowing *.cdn.atlassian-us-gov-mod.com in their firewall or proxy settings.
The Gantt Chart page fails to complete loading and stops partway through. This issue appears to have started occurring after the release of Version 2.17.0. It is not affecting all environments, but has been reported by some customers. We are currently investigating the root cause of this problem.