Some or all of the Gantt is not displayed in the Gantt list view
Incident Report for WBS Gantt-Chart for Jira Cloud
Postmortem

Incident summary

There was a bug that temporarily prevented some or all of the Gantt from being displayed in the Gantt list view.

Leadup

We have applied a patch to WBS Gantt-Chart for Jira Cloud to fix the following bug.

https://portal.productboard.com/ricksoft-inc/5-wbs-gantt-chart-for-jira-cloud/c/181-if-too-many-filters-are-existing-in-jira-gantt-cannot-be-created?utm_medium=social&utm_source=portal_share

As a result, a bug in the patch caused this incident to occur.

Fault

The following two bugs existed in the fixed program.

  • WGC couldn't handle any filter if number of filters in Jira is less than 50.
  • WGC only takes 50 filters while Jira has more filters.

Due to these problems, some or all of the Gantt was not displayed in the Gantt list view.

Impact

This incident was experienced by all customers who were using WBS Gantt-Chart for Jira at the time of the incident.

Timeline

  • Jul 21, 2021 05:20 UTC We have applied a patch for the following problem to WBS Gantt-Chart for Jira Cloud.

  • Jul 21, 2021 05:30 UTC Tested the patch in the product environment to make sure it was working correctly.

  • Jul 21, 2021 06:06 UTC One of our customers reported that the Gantt list view was not displaying correctly.

  • Jul 21, 2021 06:54 UTC We received the report from the support team and started to investigate the cause of the problem.

  • Jul 21, 2021 07:20 UTC Incident information was registered to Statuspage.

  • Jul 21, 2021 07:56 UTC We found out why the problem occurs.

  • Jul 21, 2021 07:58 UTC Since it would take a long time to fix the program again, we decided to roll back the app to the state it was in before the patch was applied.

  • Jul 21, 2021 08:12 UTC We performed a rollback.

  • Jul 21, 2021 08:15 UTC We have confirmed that the app is running correctly.

Root cause

There were problems in both implementation and testing.

in test phase

The test cases for the fixed program were insufficient, and defects could not be detected in advance.

in implementing phase

The bugs could not be found during the source review stage.

Corrective actions

  • Increase communication between QA engineers and developers so that they can collaborate and create test cases from different perspectives.
  • Refactor the source code to improve readability and make it easier to point out possible defects during source reviews.
Posted Jul 21, 2021 - 07:43 PDT

Resolved
This incident has been resolved.
Posted Jul 21, 2021 - 01:12 PDT
Update
We found out why the problem occurs.
Posted Jul 21, 2021 - 00:56 PDT
Investigating
We are currently investigating this issue.
Posted Jul 20, 2021 - 22:20 PDT
This incident affected: WBS Gantt-Chart for Jira Cloud.