Gantt list and Gantt chart do not load in some environments
Incident Report for WBS Gantt-Chart for Jira Cloud
Postmortem

Incident summary

There was a bug that caused the Gantt Chart and Gantt Chart List screens to fail to load for users who met certain conditions.

Leadup

The problem was caused by the code of the following new feature included in 1.1.27-AC, which was released as a new version.

https://portal.productboard.com/ricksoft-inc/5-wbs-gantt-chart-for-jira-cloud/c/235-ability-to-set-monday-to-be-the-first-day-of-week-in-the-date-picker?utm_medium=social&utm_source=portal_share

Fault

The following bug existed in the 1.1.27-AC program.

  • An error occurs when the app administrator settings are not saved in the app database.

Impact

The error occurred for users who had been using WBS Gantt-Chart for Jira since Version 1.1.18-AC or earlier and had not updated their WBS Gantt-Chart for Jira administrator settings at least once.
Users who have installed the app since Version 1.1.19-AC or who have updated the administrative settings of WBS Gantt-Chart for Jira at least once are likely not to have encountered this bug.

Timeline

  • Feb 21, 2022 03:12 UTC We have released a new version of the app, 1.1.27-AC.
  • Feb 21, 2022 04:30 UTC While monitoring the logs, I observed that the number of error logs increased from before the release of 1.1.27-AC.
  • Feb 21, 2022 04:40 UTC Since most of the error logs were content that did not interfere with the use of the app, we took a wait-and-see approach.
  • Feb 21, 2022 07:00 UTC After receiving a report of the problem from the customer, we began to investigate the problem.
  • Feb 21, 2022 12:55 UTC Identified the conditions under which the problem recurs.
  • Feb 21, 2022 13:00 UTC We started to look into ways to fix the problem.
  • Feb 22, 2022 01:00 UTC We started to fix the source code.
  • Feb 22, 2022 02:30 UTC We finished fixing the source code and started testing.
  • Feb 22, 2022 04:12 UTC We deployed the fixed source code to the production environment.
  • Feb 22, 2022 04:15 UTC We started monitoring the logs.
  • Feb 22, 2022 04:23 UTC We were able to see a decrease in the error log, so we changed the status of the incident to Resolved.

Root cause

The problem arose because we had not anticipated that there would be users whose configuration data was not stored in the app database.

Corrective actions

  • The process of retrieving data from the database will be improved to prevent similar problems from occurring in the future.
  • Add a test case and run the test assuming that there is no configuration data in the app database.
Posted Feb 21, 2022 - 21:40 PST

Resolved
This incident has been resolved.
Posted Feb 21, 2022 - 20:23 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 21, 2022 - 20:21 PST
Update
We are continuing to work on a fix for this issue.
Posted Feb 21, 2022 - 07:13 PST
Identified
We have identified the cause of the problem and are working on a fix.
Posted Feb 21, 2022 - 07:12 PST
This incident affected: Gantt screen - View and Gantt screen - Edit.